Updating your nim file sets

I have been talking with James Turnbull about this and he suggested I file a bug. If not, one of us can get it going, but we tend to find better results with the original bug discoverer being involved in the patch/review cycle.

updating your nim file sets-83updating your nim file sets-43

This may be related to warning messages from my NIM configuration, but I am unsure.

err: /Stage[main]/S_base_aix_dev:: C_packages/Package[idsldap.cltbase61.rte]/ensure: change from absent to present failed: Execution of '/usr/sbin/nimclient -o cust -a installp_flags=acgw XY -a lpp_source=lpp-aix61tl7sp2 -a filesets='idsldap.cltbase61.rte'' returned 1: +-----------------------------------------------------------------------------+ Pre-installation Verification...

+-----------------------------------------------------------------------------+ Verifying selections..Verifying requisites..Results... FAILURES -------- Filesets listed in this section failed pre-installation verification and will not be installed.

Missing Filesets ---------------- The following filesets could not be found on the installation media.

If you feel these filesets really are on the media, check for typographical errors in the name specified or, if installing from directory, check for discrepancies between the Table of Contents file (.toc) and the images that reside in the directory.

'idsldap.cltbase61.rte' WARNINGS -------- Problems described in this section are not likely to be the source of any immediate or serious failures, but further actions may be necessary or desired.Multiple install types for same fileset --------------------------------------- The following filesets have both a base-level and an update fileset on the installation media at the same level. Core 6.1.1.0 X11.motifdemos 6.1.2.0 X11ksc56016.1.4.0 X11default Fonts 6.1.2.0 X11. Motif10 6.1.1.0 X11lib 6.1.2.0 X11include 6.1.4.0 Verifying requisites..Results...Since they have the same name and level, the last fileset on the installation media will be used. X11 6.1.4.0 devices.pciex.25143100251401006.1.4.0 df1080f96.1.2.0 df10006.1.2.0 14109f006.1.2.0 001050006.1.4.0 bos.terminfo.6.1.2.0 bos.data 6.1.4.0 bos.data 6.1.1.0 smit 6.1.1.0 adt 6.1.1.0 bos.pc 6.1.4.0 bos.ebcdic 6.1.4.0 bos.baltic 6.1.4.0 bos. FAILURES -------- Filesets listed in this section failed pre-installation verification and will not be installed.'idsldap.cltbase61.rte' +-----------------------------------------------------------------------------+ BUILDDATE Verification ... +-----------------------------------------------------------------------------+ Verifying build dates..FILESET STATISTICS ------------------ 1 Selected to be installed, of which: 1 FAILED pre-installation verification ---- 0 Total to be installed Pre-installation Failure/Warning Summary ---------------------------------------- Name Level Pre-installation Failure/Warning ------------------------------------------------------------------------------- 'idsldap.cltbase61.rte' Not found on the installation media 0042-001 nimclient: processing error encountered on "aixengsb302p": 0042-175 c_script: An unexpected result was returned by the "nim01p:/export/nim/scripts/aixengsb302p.script" command: See the log file: /var/adm/ras/nim.installp for details or use the "showlog" operation.notice: Finished catalog run in 13.46 seconds $ lslpp -l | grep idsldap.cltbase61 idsldap.cltbase616.1.0.40 COMMITTED Directory Server - Base Client idsldap.cltbase616.1.0.40 COMMITTED Directory Server - Base Client idsldap.cltbase616.1.0.40 COMMITTED Directory Server - Base Client err: /Stage[main]/S_base_aix_dev:: C_packages/Package[asdfa.cltbase61.rte]/ensure: change from absent to present failed: Execution of '/usr/sbin/nimclient -o cust -a installp_flags=acgw XY -a lpp_source=lpp-aix61tl7sp2 -a filesets='asdfa.cltbase61.rte'' returned 1: @Nick Bausch: The output of the failed run that you pasted shows that nimclient was trying to install a package whose name included the single quotes.That’s why it fails; if you type a bad package name from the CLI, you’ll get the same kind of error but you’ll notice that the single quotes don’t appear around the package name in the error message.